حل مشكل عدم اشتغال الفلاش بلاير على الأجهزة القديمة

ما يميز لينكس منت عن باقي التوزيعات احتوائه على الكودك و الفلاش بلاير مسبقا، و بالتالي فمن المفروض أن لا نجد أي مشاكل بهذا الصدد و لكني فوجئت بعد تثبيت لينكس منت 16 XFCE على أحد الأجهزة القديمة بأن الفيديوهات لا تعمل على أي متصفح، بعد بحث طويل اكتشفت أن الفلاش بلاير في نسخه الحديثة أصب لا يدعم المعالجات القديمة، و بالتالي وجب البحث عن نسخة قديمة من الفلاش بلاير.

للتأكد من أن عدم اشتغال الفيديو يعود للمشكل الذي ذكرته بالأعلى، وجب التأكد أولا من المعالج الموجود بجهازك.

inxi -C
سوف تظهر لك نتيجة مشابهة لهذه

CPU:       Dual core Intel Core2 Duo CPU T6670 (-MCP-) cache: 2048 KB flags: (lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx)
           Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz
 ما يهمنا هو ما هو موجود بعد كلمة flags حيث إذا وجدت sse2 فأنت غير معني بهذا الشرح أما إذا وجدت sse فيرجى متابعة الحل:

تسهيلا للشرح على القراء الأعزاء، قمت بإعادة رفع الملف المقصود بمفرده حتى أتجنب إطالة الموضوع بلا فائدة.

أولا يجب القيام بتحميل الملف الذي ستحتاجه لاحقا، 

ثانيا يجب حذف الفلاش الموجود مسبقا مع لينكس منت

sudo apt-get purge mint-flashplugin mint-flashplugin-11
 
ثالثا و أخيرا ستقوم بنسخ هذا الملف إلى مسار المتصفح الذي تستعمله. (يفضل استعمال الترمنال مع صلاحيات الروت)

على Mozilla Firefox

sudo cp ~/Downloads/libflashplayer.so /usr/lib/mozilla/plugins/

على Chromium


sudo cp ~/Downloads/libflashplayer.so/usr/lib/chromium-browser/plugins
 على Opera

sudo cp ~/Downloads/libflashplayer.so/usr/lib/opera/plugins

أعد تشغيل المتصفح و مبروك عليك.

2 comments: